HDU 1800 Flying to the Mars (哈希表)

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16360    Accepted Submission(s): 5265

Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
 
Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);

Output
For each case, output the minimum number of broomsticks on a single line.

Sample Input
  
  
4 10 20 30 04 5 2 3 4 3 4
 
Sample Output
  
  
1 2
 
Author
PPF@JLU

题解:
大概就是求n个非负整数中某个值的出现次数最多的数字,关键是输入的位数要小于30位,可以开个数组来统计,用字符串来读入,使用字符串哈希函数把非负整数哈希成对应的值,然后统计。(:其实可以排个序,然后判断就OK,但这里可以用上哈希表,就练一下吧....

AC代码;
#include<iostream>
#include<memory.h>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
#define maxn 7003
int Hash[maxn],Count[maxn],n;
int maxit;
inline int ELFhash(char*key)  //字符串hash 
{
	unsigned long h=0;
	unsigned long g;
	while(*key)
	{
		h=(h<<4)+*key++;
		g=h&0xf0000000L;
		if(g)
		h^=g>>24;
		h&=~g; 
	}
	return h;
}
inline void Hashit(char *s)
{
	int k;
	while(*s=='0')
	{
		s++;
	}
	k=ELFhash(s);
	int t=k%maxn;
	while(Hash[t]!=k&&Hash[t]!=-1)
	{
		t=(t+10)%maxn;               //开放地址法解决冲突 
	}
	if(Hash[t]==-1)
	{
		Count[t]=1; Hash[t]=k;
	} 
	else if(++Count[t]>maxit)
	 maxit=Count[t];
	 return;
}
int main()  
{  
    char str[100];
    while(~scanf("%d",&n))
    {
    	memset(Hash,-1,sizeof(Hash));
    	getchar();
    	maxit=1;
    	for(int i=0;i<n;i++)
    	{
    		gets(str);
    		Hashit(str);
    	}
    	cout<<maxit<<endl;
    }
    return 0;  
}   



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值