HDU 1162 Eddy's picture(点连通:最小生成树)

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9101    Accepted Submission(s): 4607

Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.
Input contains multiple test cases. Process to the end of file.

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
Sample Output
  
  
3.41
Author
eddy
Recommend
JGShining   |   We have carefully selected several similar problems for you:  1301 1102 1217 1142 1232 
题意:给你n个点,用最短的距离将这n个点连接起来。

题解:其实就是求最短路,点连通最短路。(实际上是求最小权的生成树,即最小生成树)
          可以上 prim,并查集,dijkstra,kruskal 等算法。。。。

AC代码:
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;

#define INF 0x3ffffff
struct point
{
	double x,y;
};
point p[105];
int n;
double ans;
double map[105][105];

void prim()
{
	double dis[105];
	double min;
	int k;
	dis[1]=0;
	for(int j=2;j<=n;j++)
	{
		dis[j]=map[1][j]; //其他点的距离 
	}
	for(int i=2;i<=n;i++) //找其他n条边 
	{
		min=INF;
		for(int j=1;j<=n;j++) 
		{
			if(dis[j]<min && dis[j]) //有可能重复 ,标志 
			{
				min=dis[j];
				k=j;
			}  				
		}
	    ans+=min; 
		dis[k]=0;
		for(int j=1;j<=n;j++)
		{
			if(map[k][j]< dis[j] && dis[j]) 
			  dis[j]=map[k][j];

		 } 
	}
}
int main()
{

	while(~scanf("%d",&n))
	{
		ans=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%lf %lf",&p[i].x,&p[i].y);
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(i==j)map[i][j]=INF;
				else map[i][j]=sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));

			}
		}
		prim();
		printf("%.2f\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值