HDU 3555 Bomb (数位dp)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 15699    Accepted Submission(s): 5715

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
  
  
3 1 50 500
Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
Author
fatboy_cw@WHU
Source
Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:  3554 3556 3557 3558 3559 

题解:把HDU 2089 改改就行了.......我还因为一个if判断条件吃了几发TLE....

AC代码:
//#include<bits/stdc++.h>
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<string.h>
using namespace std;
typedef long long ll;
int dig[63];
ll dp[63][2][63];

ll dfs(int pos,bool have,int last,int flag)
{
    int i;
    if (pos < 0) return have;
    if (flag==0 && dp[pos][have][last]!=-1) return dp[pos][have][last];
    
    int n=flag ? dig[pos] : 9;
    ll ans=0;
    for(i=0;i<=n;i++)
    {
        if (last==4 && i==9) ans += dfs(pos-1,true,i,flag && (i==n));
        else ans+=dfs(pos-1,have,i,flag && (i==n));
    }
    if (flag==0)
    {
        dp[pos][have][last]=ans;
    }
    return ans;
}
ll solve(ll x)
{
	int len = 0; 
	while(x)
	{
		dig[len++] = x % 10;
		x /= 10;
	}
	return dfs(len-1,0,0,1);
}

int main()
{
	ll x;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(dp,-1,sizeof(dp));
		scanf("%I64d",&x);
		printf("%I64d\n",solve(x));
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值