HDU 1896 Stones (优先队列)

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2234    Accepted Submission(s): 1456

Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
Output
Just output one line for one test case, as described in the Description.
Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
Sample Output
  
  
11 12
Author
Sempr|CrazyBird|hust07p43
Source
Recommend
lcy   |   We have carefully selected several similar problems for you:  1892 1899 1895 1894 1897 

题解:在一条直线道路上有n个石头,向前走遇到一个数一个,如果遇到的是位置是第奇数个那就把这个石头往前扔距离stone.d, 如果是第偶数个,就跳过不管。
问遇到的最后一个石头距离出发点的位置是多少。

每遇到第奇数个石头,就将其加上stone.d,放回到优先队列(priority_queue)中,然后再去掉一个石头,遇到第偶数个石头就跳过....

AC代码:
#include<bits/stdc++.h>
using namespace std;

struct node
{
	int p,d;
};
struct cmp
{
	bool operator()(const node a,const node b)
	{
		if(a.p!=b.p)return a.p>b.p;
		else return a.d>b.d;
	}
};
int t;
int N;
node stone;
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&N);
		priority_queue<node,vector<node>,cmp>q;
		for(int i=0;i<N;i++)
		{
			scanf("%d %d",&stone.p,&stone.d);
			q.push(stone);
		}
		int flag=1;
		while(!q.empty())
		{
			stone = q.top();
			q.pop();
			if(flag)
			{
				stone.p += stone.d;
				q.push(stone);
			}
			flag=!flag;//偶数就跳过 
		}
		printf("%d\n",stone.p);
	}
}


 
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值