PAT甲级1015. Reversible Primes (20)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

Customized Test Case
Case #1:
Input:
2 2
Output:
No
(2在10进制下就是素数,转化成二进制还是素数,素数是和进制表示无关的;2的二进制表示是10,反过来是1,1不是素数)
Case #2:
Input:
32 10
Output:
No

#include <iostream>
using namespace std;
#include <vector>

/*素数判断*/ 
bool isPrime(int N){
    if(N==1) return false;
    if(N==2) return true;
    for(int i=2;i*i<=N;i++){
        if(N%i==0) return false; 
    }
    return true;
}

/*进制转换并Reverse*/ 
int Convert_to_R(int N,int R){
    /*求N在R进制下的各位数字并逆序保存在vector中*/
    vector<int> Ans;
    while(N>0){
        Ans.push_back(N%R);
        N/=R;
    }
    /*Reverse后的R进制数转化为10进制*/
    int result=0;
    for(int i=0;i<Ans.size();i++) {
        result=Ans[i]+result*R;
    }
    return result;
}

int main(){
    int num;
    cin>>num; 
    while(num>0){
        int radix;
        cin>>radix;
        if(!isPrime(num)) cout<<"No"<<endl;
        else {
            int reverse=Convert_to_R(num,radix);
            if(isPrime(reverse)) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
        }
        cin>>num;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值