PAT甲级1038. Recover the Smallest Number (30)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Do not output leading zeros.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

其实是一道非常简单的排序题!
注意有答案为0的情况。

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

bool compare(string A,string B){
    return (A+B)<(B+A);
}

int main(){
    int N;
    cin>>N;

    vector<string> V(N);
    for(int i=0;i<N;i++) cin>>V[i];
    sort(V.begin(),V.end(),compare);

    string ans;
    for(int i=0;i<N;i++) ans+=V[i];

    int i=0;
    for(i=0;i<ans.length();i++) {
        if(ans[i]!='0') break;
    }

    if(i==ans.length()) cout<<0;
    else cout<<ans.substr(i);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值