hdu 5879 分析



链接:戳这里


Cure

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n.
 
Input
There are multiple cases.
For each test case, there is a single line, containing a single positive integer n. 
The input file is at most 1M.
 
Output
The required sum, rounded to the fifth digits after the decimal point.
 
Sample Input
1
2
4
8
15
 
Sample Output
1.00000
1.25000
1.42361
1.52742
1.58044
 

题意:

给出n,计算1/i*i (1<=i<=n)的和,保留5位小数


思路:

大概n=1000000时,保留的五位小数就不会在有变化了


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<list>
#include<stack>
#include<iomanip>
#include<cmath>
#include<bitset>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
typedef long double ld;
#define INF (1ll<<60)-1
#define Max 1e9
using namespace std;
long double anw[1000100];
char s[30];
int main(){
    anw[0]=0.0;
    for(int i=1;i<=1000000;i++){
        anw[i]=anw[i-1]+1.0/(1.0*i*1.0*i);
    }
    while(scanf("%s",&s)!=EOF){
        int len=strlen(s);
        if(len>=7)printf("1.64493\n");
        else {
            int n=0;
            for(int i=0;i<len;i++) n=n*10+s[i]-'0';
            printf("%.5f\n",(double)anw[n]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值