HDU-5879-思维题

Given an integer n, we only want to know the sum of 1/k2 where k from 1 to n

.

Input

There are multiple cases.
For each test case, there is a single line, containing a single positive integer n

.
The input file is at most 1M.

Output

The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
4
8
15

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

当n大于120000时,其他的结果趋于一个值,所以只要算到120000左右就可以了。

因为字符型数组的问题卡了好久。

#include<iostream>
#include<cstring> 
#include<string>
using namespace std;
#define maxn 120000
double a[maxn];
void init()
{
	for(int i = 1; i <maxn; i ++)
		a[i] = a[i-1] + (1.0/i)*(1.0/i);
}
int main()
{
	string s;
	init();
	while(getline(cin,s))
	{
		int len = s.length();
		int num = 0; 
		for(int i = 0; i < len; i ++)
		{
			num = num*10 + s[i]-'0';
			if(num>=maxn)
				break;
		}
		if(num>=maxn)
			printf("%.5lf\n",a[maxn-1]);
		else
			printf("%.5lf\n",a[num]);
	
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值