hdu 4294 Multiple

Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 534    Accepted Submission(s): 138


Problem Description
  Given a positive integer N, you’re to solve the following problem:
  Find a positive multiple of N, says M, that contains minimal number of different digits in base-K notation. If there’re several solutions, you should output the numerical smallest one. By saying numerical smallest one, we compar their numerical value, so 0xA hex < 11 dec.
  You may assume that 1 <= N <= 10 4 and 2 <= K <= 10.
 

Input
  There’re several (less than 50) test cases, one case per line.
  For each test case, there is a line with two integers separated by a single space, N and K.
  Please process until EOF (End Of File).
 

Output
  For each test case, you should print a single integer one line, representing M in base-K notation,the answer.
 

Sample Input
  
  
10 8 2 3 7 5
 

Sample Output
  
  
2222 2 111111
 

Source
 


题目:在K进制下,用最少的不同的数,表示成n的倍数

首先要得到一个结论,就是最多用两个数就行了。

证明 :对于一个数字a,可以构造出的数字有a,aa,aaa,aaaa,aaaaa,……

每一个数对于n都有一个余数,余数最多有n个,根据鸽巢原理,前n+1个数中,必然有两个余数相等

那么二者之差,必定为n的倍数,形式为a……a0……0。

有这个结论,就简单了,先枚举一个数,然后枚举两个数,BFS即可


代码:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int N=10002;
int n,c,k,l;
int pre[N],res[N],step[N],num[2];
char ans[N],re[N];
bool bfs()
{
	queue<int> Q;
	int i,p,q;
	memset(step,0,sizeof(step));
	for(i=0;i<c;i++)
	{
		int y=num[i]%n;
		if(!num[i]||step[y]) continue;
		step[y]=1;
		pre[y]=-1;
		res[y]=num[i];
		Q.push(y);
	}
	while(!Q.empty())
	{
		p=Q.front();Q.pop();
		if(p==0) return true;
		if(l&&step[p]>l) return false;
		for(i=0;i<c;i++)
		{
			q=(p*k+num[i])%n;
			if(!step[q])
			{
				step[q]=step[p]+1;
				pre[q]=p;
				res[q]=num[i];
				Q.push(q);
			}
		}
	}
	return false;
}
int l1;
void solve(int i)
{
	if(pre[i]!=-1) solve(pre[i]);
	re[l1++]=res[i]+'0';
}
bool judge()
{
	int i;
	if(!l||l1<l) return true;
	if(l1>l) return false;
	for(i=0;i<l;i++)
	{
		if(re[i]<ans[i]) return true;
		if(re[i]>ans[i]) return false;
	}
	return false;
}
int main()
{
	int i,j;
	while(~scanf("%d%d",&n,&k))
	{
		l=0;
		bool f=false;
		for(i=1;i<k;i++)
		{
			num[0]=i;c=1;
			if(bfs())
			{
				f=true;
				l1=0;
				solve(0);
				if(judge()) {l=l1;memcpy(ans,re,sizeof(ans));}
			}
		}
		if(!f)
		{
			for(i=0;i<k;i++)for(j=i+1;j<k;j++)
			{
				num[0]=i;num[1]=j;c=2;
				if(bfs())
				{
					l1=0;
					solve(0);
					if(judge()) {l=l1;memcpy(ans,re,sizeof(ans));}
				}
			}
		}
		for(i=0;i<l;i++)putchar(ans[i]);
		puts("");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值