poj 2912 Rochambeau

Rochambeau
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1507 Accepted: 514

Description

N children are playing Rochambeau (scissors-rock-cloth) game with you. One of them is the judge. The rest children are divided into three groups (it is possible that some group is empty). You don’t know who is the judge, or how the children are grouped. Then the children start playing Rochambeau game for M rounds. Each round two children are arbitrarily selected to play Rochambeau for one once, and you will be told the outcome while not knowing which gesture the children presented. It is known that the children in the same group would present the same gesture (hence, two children in the same group always get draw when playing) and different groups for different gestures. The judge would present gesture randomly each time, hence no one knows what gesture the judge would present. Can you guess who is the judge after after the game ends? If you can, after how many rounds can you find out the judge at the earliest?

Input

Input contains multiple test cases. Each test case starts with two integers N and M (1 ≤ N ≤ 500, 0 ≤ M ≤ 2,000) in one line, which are the number of children and the number of rounds. Following are M lines, each line contains two integers in [0, N) separated by one symbol. The two integers are the IDs of the two children selected to play Rochambeau for this round. The symbol may be “=”, “>” or “<”, referring to a draw, that first child wins and that second child wins respectively.

Output

There is only one line for each test case. If the judge can be found, print the ID of the judge, and the least number of rounds after which the judge can be uniquely determined. If the judge can not be found, or the outcomes of the Mrounds of game are inconsistent, print the corresponding message.

Sample Input

3 3
0<1
1<2
2<0
3 5
0<1
0>1
1<2
1>2
0<2
4 4
0<1
0>1
2<3
2>3
1 0

Sample Output

Can not determine
Player 1 can be determined to be the judge after 4 lines
Impossible
Player 0 can be determined to be the judge after 0 lines
 
 
分析:和poj 1182(食物链)很相似,做法一样
    对于这题,要枚举每个人是judge的情况,如果对于某个人作为judge的情况下,所有round都合法(除包括judge的round),那么这个人就有可能是judge。如果这样的人不存在,输出"Impossible";如果有多个,输出"Can not determine";如果有唯一的,输出这个人编号。
    其次,唯一情况下如何确定判断出judge的最少round呢?我们知道,此时其他人都不可能judge,对于这些人,过程中可以知道判断出他不是judge的最少round,求出这些round中最大的即我们所求!
#include<cstdio>
const int N=500;
const int M=2000;
int p[N],r[N],n,a[M],b[M];
char op[M];
int max(int a,int b){return a>b?a:b;}
int findset(int x)
{
	if(x!=p[x])
	{
		int fx=findset(p[x]);
		r[x]=(r[x]+r[p[x]])%3;
		p[x]=fx;
	}
	return p[x];
}
int main()
{
	int m,i,j;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=0;i<m;i++)
		{
			scanf("%d%c%d",&a[i],&op[i],&b[i]);
			if(op[i]=='=')op[i]=0;
			else if(op[i]=='>')op[i]=1;
			else op[i]=2;
		}
		int judge=-1,round=0;
		bool only=1;
		for(i=0;i<n;i++)
		{
			bool f=1;
			for(j=0;j<n;j++)p[j]=j,r[j]=0;
			for(j=0;j<m;j++)
			{
				if(a[j]==i||b[j]==i)continue;
				int fx=findset(a[j]),fy=findset(b[j]);
				if(fx==fy)
				{
					if(r[b[j]]!=(r[a[j]]+op[j])%3)
					{
						f=0;
						round=max(round,j+1);
						break;
					}
				}
				else
				{
					p[fy]=fx;
					r[fy]=(r[a[j]]-r[b[j]]+op[j]+3)%3;
				}
			}
			if(f)
			{
				if(judge==-1)judge=i;
				else {only=0;break;}
			}
		}
		if(judge==-1)puts("Impossible");
		else 
		{
			if(!only)puts("Can not determine");
			else printf("Player %d can be determined to be the judge after %d lines\n",judge,round);
		}
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值