HDU 1025 Constructing Roads In JGShining's Kingdom(DP,LIS最长上升子序列)

题目描述:
Constructing Roads In JGShining’s Kingdom
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Description
JGShining’s kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they’re unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don’t wanna build a road with other poor ones, and rich ones also can’t abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities … And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output
For each test case, output the result in the form of sample.
You should tell JGShining what’s the maximal number of road(s) can be built.

Sample Input
2
1 2
2 1
3
1 2
2 3
3 1

Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

题目大意:
就是一个过道,一边是穷的国家,一边是富有的国家,分别从1开始依次排列现在有一些路连接穷的国家和富有的国家,然后问不交叉的最多的路的条数是多少

题目分析:
其实画一个图就可以很明显的看出来了,先定一边,比如让贫穷的国家从小到大排列,然后连接存在的路,只有所连的富有的国家的序号是从小到大的才能保证路不交叉,比如P1,R1,P2,R2,P1

#include "cstdio"
#include "algorithm"
#define INF 1e6
using namespace std;
struct node
{
    int p,r;
};
node city[500000+5];
int dp[500000+5];
bool cmp(node a,node b)
{
    return a.p<b.p;
}
int main()
{
    int n,i,cnt=0;
    while(scanf("%d",&n)!=EOF)
    {
        cnt++;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&city[i].p,&city[i].r);
        }
        sort(city,city+n,cmp);
        fill(dp,dp+n,INF);
    //我认为这是LIS问题最好的方法,dp[i]表示长度为i+1的序列的最后一个值
    //具体含义我认为仔细揣摩就能明白
        for(i=0;i<n;i++)
        {
            *lower_bound(dp,dp+n,city[i].r)=city[i].r;
        }
        int res=lower_bound(dp,dp+n,INF)-dp;
        printf("Case %d:\n",cnt);
        if(res==1){
            printf("My king, at most %d road can be built.\n\n",res);
        }else{
            printf("My king, at most %d roads can be built.\n\n",res);
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值