poj1724 ROADS

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 

  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

 

本题用了最优性剪枝,

最优性剪枝:
1) 如果当前已经找到的最优路径长度为 L , 那么在继续搜索的过程中,总长度 已经大 于 等于L的走法,就可以直接放弃不用到底了
保存中间计算结果用于最优性剪枝:
2) 用midL [k][m] 表示:走到城市 k时总过路费为 m的条件下,最优路径长度。若在 后续的搜索中,再次走到 k时,如果总路费恰好为 m,且此时的路径长度已经超过 midL [k][m], 则不必再走下去了

第一次用数组存储的,运行正确,提交wrong,不知道什么原因。。。。。。???

#include<iostream>
#include<cstdio>
#include<cstring>
const int p =110;
using namespace std;
int a[p][p];
int k,n,r;
int visit[p];
int tnum,lnum;
int minlen=1<<30;//起初定义成无穷大;//当前找到的最优路径的长度
int midl[110][10100];
struct Road{
    int l;
    int t;
}road[p][p];
void dfs(int x){
  if(x==n){
        minlen=min(minlen,lnum);
        //printf("min:%d\n",minlen);
        return;
  }
  for(int j=1;j<=n;j++){
   if(road[x][j].l&&!visit[j]){
    int cost=tnum+road[x][j].t;
    //printf("tnum:%dcost:%d\n",tnum,cost);
    if(cost>=k){
            //printf("1111\n");
        continue;
    }
    if(lnum+road[x][j].l>=minlen||lnum+road[x][j].l>=midl[j][cost])
    {
            continue;
    }
    tnum=tnum+road[x][j].t;
    lnum=lnum+road[x][j].l;
    midl[j][cost]=lnum;
    visit[j]=1;
    //printf("j1:%d\n",j);
    dfs(j);
    visit[j]=0;
    tnum=tnum-road[x][j].t;
    lnum=lnum-road[x][j].l;
   }
  }
}
int main()
{
int a1,a2,l1,t1;

scanf("%d%d%d",&k,&n,&r);
memset(road,0,sizeof(road));
for(int i=1;i<=r;i++){
    scanf("%d%d%d%d",&a1,&a2,&l1,&t1);
    if(a1!=a2){
    road[a1][a2].l=l1;
    road[a1][a2].t=t1;
    }
    //road[a2][a1].l=l1;
    //road[a2][a1].t=t1;
}
/*for(int i=1;i<=n;i++)
{
    for(int j=1;j<=n;j++)
    {

        cout<<road[i][j].l<<" ";
    }
    cout<<endl;
}*/
for(int i=0;i<110;i++){
    for(int j=0;j<10100;j++){
        midl[i][j]=1<<30;
    }
}
memset(visit,0,sizeof(visit));
tnum=0;
lnum=0;
visit[1]=1;
minlen=1<<30;
dfs(1);
if(minlen<(1<<30))
printf("%d\n",minlen);
else
    printf("-1\n");
}

 

然后根据用了vector存放。。就可以了,大写的问号????

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
const int p =110;
using namespace std;
int a[p][p];
int k,n,r;
int visit[p];
int tnum,lnum;
int minlen=1<<30;//起初定义成无穷大;//当前找到的最优路径的长度
int midl[110][10100];
struct Road{
    int d;
    int l;
    int t;
};
vector<Road> road[p];
void dfs(int x){
  if(x==n){
        minlen=min(minlen,lnum);
        //printf("min:%d\n",minlen);
        return;
  }
  for(int j=0;j<road[x].size();j++){
    int d=road[x][j].d;
   //printf("d:%d\n",d);
   if(!visit[d]){
    int cost=tnum+road[x][j].t;
    //printf("tnum:%dcost:%d\n",tnum,cost);
    if(cost>k){
            //printf("1111\n");
        continue;
    }
    if(lnum+road[x][j].l>=minlen||lnum+road[x][j].l>=midl[d][cost])//剪枝
    {
            continue;
    }
    tnum=tnum+road[x][j].t;
    lnum=lnum+road[x][j].l;
    midl[d][cost]=lnum;
    visit[d]=1;
    //printf("j1:%d\n",j);
    dfs(d);
    visit[d]=0;
    tnum=tnum-road[x][j].t;
    lnum=lnum-road[x][j].l;
   }
  }
}
int main()
{
int a1,a2,l1,t1;

scanf("%d%d%d",&k,&n,&r);
memset(road,0,sizeof(road));
for(int i=1;i<=r;i++){
    int s;
    Road r;
    scanf("%d%d%d%d",&s,&r.d,&r.l,&r.t);
    if(s!=r.d){
    road[s].push_back(r);
    }
    //road[a2][a1].l=l1;
    //road[a2][a1].t=t1;
}
/*for(int i=1;i<=n;i++)
{
    for(int j=1;j<=n;j++)
    {

        cout<<road[i][j].l<<" ";
    }
    cout<<endl;
}*/
for(int i=0;i<110;i++){
    for(int j=0;j<10100;j++){
        midl[i][j]=1<<30;
    }
}
memset(visit,0,sizeof(visit));
tnum=0;
lnum=0;
visit[1]=1;
minlen=1<<30;
dfs(1);
if(minlen<(1<<30))
printf("%d\n",minlen);
else
    printf("-1\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值