Prime Ring Problem (回溯法加素数判断)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

回溯法+素数判断

从问题的某一种可能出发, 搜索从这种情况出发所能达到的所有可能, 当这一条路走到” 尽头 “的时候, 再倒回出发点, 从另一个可能出发, 继续搜索. 这种不断” 回溯 “寻找解的方法, 称作” 回溯法 “。

理解此回溯法,按照深搜优先的顺序依次寻找。。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int s=0;
int num=0;
int b[25];
int vis[25];
int n;
bool judge(int t){
    if(t==2)
        return true;
    for(int i=2;i<t;i++){
        if(t%i==0)
            return false;
    }
        return true;
}
void dfs(int u){
    if(u==n&&judge(b[0]+b[u-1])){//判断最后一位数和第一位相加是否为素数
        for(int i=0;i<n;i++){
            if(i==n-1)
                printf("%d\n",b[i]);
            else
                printf("%d ",b[i]);
        }
    }
    else{
        for(int i=2;i<=n;i++){
        if(!vis[i]&&judge(i+b[u-1])){
            num++;
            vis[i]=1;
            b[u]=i;
            dfs(u+1);
            //printf("i=%d\n",i);
            vis[i]=0;
        }
    }
    }
}
int main(){
    while(scanf("%d",&n)!=EOF){
        s++;
        memset(vis,0,sizeof(int));
        memset(b,0,sizeof(b));
        printf("Case %d:\n",s);
        b[0]=1;
        dfs(1);
        printf("\n");//注意格式
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值