L2-012 关于堆的判断 (25 分)
将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:
x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
题目链接
输入格式
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。
输出格式
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。
样例输入
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
样例输出
F
T
F
T
思路
- 实现小顶堆,优先队列
- 标记每个数的位置
- 判断输入的不同情况
坑点
- 要理解堆
代码
#include<bits/stdc++.h>
using namespace std;
const int N=1e5+10;
int n,m;
int a[N];
void build(int u)//实现堆操作
{
while(u/2>0&&a[u/2]>a[u])
{
swap(a[u/2],a[u]);
u/=2;
}
}
map<int,int>mp;
int main()
{
int x,y;
cin>>n>>m;
string s;
for(int i=1;i<=n;i++)
{
cin>>a[i];
build(i);
}
for(int i=1;i<=n;i++)
{
mp[a[i]]=i;
}
for(int i=0;i<m;i++)
{
cin>>x>>s;
if(s[0]=='a')//问两个点是否是兄弟节点
{
cin>>y>>s>>s;
if(mp[x]/2==mp[y]/2)
{
cout<<"T"<<endl;
}
else{
cout<<"F"<<endl;
}
}
else
{
cin>>s>>s;
if(s[0]=='r')//是否为根节点
{
if(mp[x]==1)
{
cout<<"T"<<endl;
}
else{
cout<<"F"<<endl;
}
}
else if(s[0]=='p')//x是不是y的父亲
{
cin>>s>>y;
if(mp[x]==mp[y]/2)
{
cout<<"T"<<endl;
}
else{
cout<<"F"<<endl;
}
}
else//y是不是x的父亲节点
{
cin>>s>>y;
if(mp[x]/2==mp[y])
{
cout<<"T"<<endl;
}
else{
cout<<"F"<<endl;
}
}
}
}
return 0;
}
总结
学习小顶堆大顶堆,可以先从优先队列学起