PAT甲级 1001 A+B Format (20 分)

题目:

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

代码:

#include<stdio.h>
#include<math.h>
int main(){
    int a,b,sum;
    int m,n,x;
    scanf("%d %d",&a,&b);
    sum=a+b;
    if(sum>-1000&&sum<1000)
    {
        printf("%d\n",sum);
    }
    else if(sum>-1000000&&sum<1000000)
    {
          //大于四位数的结果用逗号分成三位数 
           m=sum/1000;
           n=abs(sum%1000);//余数的绝对值 
           printf("%d,%03d\n",m,n);//03d,不足三位的前面补0 
    }
    else
    {
        m=sum/1000000;
        n=abs(sum%1000000);
        x=abs(n%1000);
        printf("%d,%03d,%03d",m,abs(n/1000),x);
    } 
    return 0;
 } 

没能一次性通过,错误的原因可能有以下几点:

1、三种可能性没有写完。

2、需要理清逻辑关系,什么时候保留商,什么时候保留除数。

3、有一次提交上去时一直是19分,显示测试点10有错误,但是反复看了没有逻辑问题,最后试着在第三种情况下的输出中n/1000上取绝对值,提交上去后就显示对了。所以很多时候都是败在细节上。

啾&嘟

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值