安装pyecharts1.8.0版本后导入pyecharts模块绘图时报错: “所有图表类型将在 v1.9.0 版本开始强制使用 ChartItem 进行数据项配置 ”的解决方法

更多编程教程请到:菜鸟教程 https://www.piaodoo.com/

友情链接:

高州阳光论坛https://www.hnthzk.com/

安装pyecharts1.8.0版本后导入pyecharts模块绘图时报错: “所有图表类型将在 v1.9.0 版本开始强制使用 ChartItem 进行数据项配置 ”的解决方法;

作者这里可能仅仅只是针对某些情况,希望对你有所帮助!

安装pyecharts:

对于学习大数据可视化萌新来说我们一般都会使用 pip install pyecharts 命令来安装pyecharts包,因为这个pip命令是最简单快捷的方式,但是使用这个命令一般来说默认安装的是最新版本的包。
当我们安装完成后去找学习资料时,就会发现多个版本

这种导入方式;

这种.

但是当我们使用的时候就会发现提示报错

在这里插入图片描述

3…或者去官网找实列来参考pyecharts网站http://gallery.pyecharts.org/#/README
解决模块导入问题

在这里插入图片描述

当我们把实例拿来运行时就可能出现这个报错!

“所有图表类型将在 v1.9.0 版本开始强制使用 ChartItem 进行数据项配置!”

其实这只是我们的大一粗心造成的,在pyecharts网站上有说明实例是基于1.7.1版本设计的,而我们用pip命令默认安装的是最新版,又因为pyecharts是开源社区版本更新迭代较快,1.8.1的版本与1.7.1不兼容,所以才会出现这样的错误提示!

在这里插入图片描述

解决的方法很简单

安装有pycharm的到文件->设置里面找到pyecharts

在这里插入图片描述

2.里面找到pyecharts,双击

在这里插入图片描述在这里插入图片描述

安装为1.7.1就可以啦!

第二种方法使用pip 命令

1.wid+R打开控制命令,输入cmd

在这里插入图片描述

2 卸载使用pip uninstall pagename 命令,以you-get为例

在这里插入图片描述

3. 安装指定版本 pip install pyechatrs==1.7.1

在这里插入图片描述

4. 查询时用包名+ --vision

总结

到此这篇关于安装pyecharts1.8.0版本后导入pyecharts模块绘图时报错: “所有图表类型将在 v1.9.0 版本开始强制使用 ChartItem 进行数据项配置 ”的解决方法的文章就介绍到这了,更多相关安装pyecharts1.8.0导入pyecharts模块绘图时报错内容请搜索菜鸟教程www.piaodoo.com以前的文章或继续浏览下面的相关文章希望大家以后多多支持菜鸟教程www.piaodoo.com!

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 数字20 设计师:CSDN官方博客 返回首页