HDU 1969:Pie【二分法】

Pie

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6452    Accepted Submission(s): 2429


Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
  
  
25.1327 3.1416 50.2655
题意:第一行输入N表示N组测试数据,第二行输入饼的数量和小朋友们的个数M,第三行输入每个饼的半径,要求把饼分成面积相等的M加一份,而且还是整块的要,输出每块的最大面积,注意精度~pi取acos(-1.0);
AC-code:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define PI acos(-1.0)
using namespace std;
int a,b;
double s[10005];
bool ok(double x)
{
	int sum=0;
	for(int i=0;i<a;i++)
		sum+=floor(s[i]/x);
	if(sum>=b+1)
		return 1;
	else 
		return 0;
}

int main()
{
	int n;
	double l,r,ri,mid;
	scanf("%d",&n);
	while(n--)
	{
		//memset(a,0,sizeof(s));
		scanf("%d%d",&a,&b);
		double Max=0;
		for(int i=0;i<a;i++)
		{
			scanf("%lf",&ri);
			s[i]=ri*ri*PI;
			Max=max(Max,s[i]);
		}
			
		l=0;r=Max;
		while(r-l>1e-6)
		{
			mid=(l+r)/2;
			if(ok(mid))
				l=mid;
			else
				r=mid;
		}
		printf("%.4lf\n",r);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值