WHOJ 1603 - Minimum Sum【思维】

Problem 1603 - Minimum Sum
Time Limit: 2000MS    Memory Limit: 65536KB   
Total Submit: 561   Accepted: 154   Special Judge: No
Description

There are n numbers A[1] , A[2] .... A[n], you can select m numbers of it A[B[1]] , A[B[2]] ... A[B[m]]  ( 1 <= B[1] < B[2] .... B[m] <= n ) such that Sum as small as possible.

Sum is sum of abs( A[B[i]]-A[B[j]] ) when 1 <= i < j <= m.

Input
There are multiple test cases.
First line of each case contains two integers n and m.( 1 <= m <= n <= 100000 )
Next line contains n integers A[1] , A[2] .... A[n].( 0 <= A[i] <= 100000 )
It's guaranteed that the sum of n is not larger than 1000000.
Output
For each test case, output minimum Sum in a line.
Sample Input
4 2
5 1 7 10
5 3
1 8 6 3 10
Sample Output
2
8
AC-code:
<pre name="code" class="cpp">#include<cstdio>
#include<algorithm>
using namespace std;
int s[100005];
int main()
{
	int n,m,i,k,j;
	long long sum,ans;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=1;i<=n;i++)
			scanf("%d",&s[i]);
		sort(s+1,s+n+1);
		ans=0x3f3f3f3f;
		for(i=1;i<=n-m+1;i++)//每个可能的数列的起始位置 
		{
			sum=0;
			for(j=1;j<=m;j++)
				sum+=(2*j-m-1)*s[i+j-1];//2*j-m-1=(j-1)-(m-j)即该数在该序列中前面的数的个数减去后面的数的个数 
			if(sum<ans)
				ans=sum;
		}
		printf("%lld\n",ans);
	}
	return 0;
}


 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值