第十六周:[Sicily]1321. Robot

Description
Karell Incorporated has designed a new exploration robot that has the ability to explore new terrains, this new robot can move in all kinds of terrain, it only needs more fuel to move in rough terrains, and less fuel in plain terrains. The only problem this robot has is that it can only move orthogonally, the robot can only move to the grids that are at the North, East, South or West of its position.
The Karell`s robot can communicate to a satellite dish to have a picture of the terrain that is going to explore, so it can select the best route to the ending point, The robot always choose the path that needs the minimum fuel to complete its exploration, however the scientist that are experimenting with the robot, need a program that computes the path that would need the minimum amount of fuel. The maximum amount of fuel that the robot can handle is 9999 units
The Terrain that the robot receives from the satellite is divided into a grid, where each cell of the grid is assigned to the amount of fuel the robot would need to pass thought that cell. The robot also receives the starting and ending coordinates of the exploration area.
Input
The first line of the input file is the number of tests that must be examined.
The first line of the test is the number of rows and columns that the grid will contain. The rows and columns will be 0 < row 100 , 0 < column 100
The next lines are the data of the terrain grid
The last line of the test has the starting and ending coordinates.
Output
One line, for each test will have the amount of fuel needed by the robot
Sample Input
3
5 5
1 1 5 3 2
4 1 4 2 6
3 1 1 3 3
5 2 3 1 2
2 1 1 1 1
1 1 5 5
5 4
2 2 15 1
5 1 15 1
5 3 10 1
5 2 1 1
8 13 2 15
1 1 1 4
10 10
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 10 10
Sample Output
10
15
19


读懂题意后,即为求给定起点至终点的单源最短路,处理好输入后使用dijkstra算法求单源最短路。


#include<iostream>
#include<vector>
using namespace std;

#define INF 10000
int map[101][101],dis[101][101],c,r,s_y,s_x,e_y,e_x;

struct node{
    int x,y;
    node(int xx,int yy){
        x = xx;
        y = yy;
    }
};

void init_dis(){
    for(int i = 1;i <= r;i++)
        for(int j = 1;j <= c;j++)
            dis[i][j] = INF;
    dis[s_y][s_x] = 0;
}

int dijkstra(){
    init_dis();
    bool visited[101][101] = {false};
    vector<node> path_set;
    path_set.push_back(node(s_x,s_y));
    visited[s_y][s_x] = true;
    dis[s_y][s_x] = map[s_y][s_x];
    while(!visited[e_y][e_x]){
        node cur_min(0,0);
        int min_weight = INF;
        for(int i = 0;i < path_set.size();i++){
            node cur_n = node(path_set[i].x,path_set[i].y);
            if(cur_n.x - 1 > 0 && !visited[cur_n.y][cur_n.x - 1]){
                if(dis[cur_n.y][cur_n.x] + map[cur_n.y][cur_n.x - 1] < dis[cur_n.y][cur_n.x - 1])
                    dis[cur_n.y][cur_n.x - 1] = dis[cur_n.y][cur_n.x] + map[cur_n.y][cur_n.x - 1];
                if(dis[cur_n.y][cur_n.x - 1] < min_weight){
                    cur_min.y = cur_n.y;
                    cur_min.x = cur_n.x - 1;
                    min_weight = dis[cur_n.y][cur_n.x - 1];
                }
            }
            if(cur_n.x + 1 <= c && !visited[cur_n.y][cur_n.x + 1]){
                if(dis[cur_n.y][cur_n.x] + map[cur_n.y][cur_n.x + 1] < dis[cur_n.y][cur_n.x + 1])
                    dis[cur_n.y][cur_n.x + 1] = dis[cur_n.y][cur_n.x] + map[cur_n.y][cur_n.x + 1];
                if(dis[cur_n.y][cur_n.x + 1] < min_weight){
                    cur_min.y = cur_n.y;
                    cur_min.x = cur_n.x + 1;
                    min_weight = dis[cur_n.y][cur_n.x + 1];
                }
            }
            if(cur_n.y + 1 <= r && !visited[cur_n.y + 1][cur_n.x]){
                if(dis[cur_n.y][cur_n.x] + map[cur_n.y + 1][cur_n.x] < dis[cur_n.y + 1][cur_n.x])
                    dis[cur_n.y + 1][cur_n.x] = dis[cur_n.y][cur_n.x] + map[cur_n.y + 1][cur_n.x];
                if(dis[cur_n.y + 1][cur_n.x] < min_weight){
                    cur_min.y = cur_n.y + 1;
                    cur_min.x = cur_n.x;
                    min_weight = dis[cur_n.y + 1][cur_n.x];
                }
            }
            if(cur_n.y - 1 > 0 && !visited[cur_n.y - 1][cur_n.x]){
                if(dis[cur_n.y][cur_n.x] + map[cur_n.y - 1][cur_n.x] < dis[cur_n.y - 1][cur_n.x])
                    dis[cur_n.y - 1][cur_n.x] = dis[cur_n.y][cur_n.x] + map[cur_n.y - 1][cur_n.x];
                if(dis[cur_n.y - 1][cur_n.x] < min_weight){
                    cur_min.y = cur_n.y - 1;
                    cur_min.x = cur_n.x;
                    min_weight = dis[cur_n.y - 1][cur_n.x];
                }
            }
        }
        if(cur_min.y != 0 && cur_min.x != 0){
            visited[cur_min.y][cur_min.x] = true;
            path_set.push_back(node(cur_min.x,cur_min.y));
        }
    }
    return dis[e_y][e_x];
}

int main(){
    int n;
    cin>>n;
    while(n--){
        int i,j;
        cin>>r>>c;
        for(i = 1;i <= r;i++)
            for(j = 1;j <= c;j++)
                cin>>map[i][j];
        cin>>s_y>>s_x>>e_y>>e_x;
        cout<<dijkstra()<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值