ZOJ-1295 字符串逆序

1295:字符串逆序输出

Sample Input

3
Frankly, I don't think we'll make much
money out of this scheme.
madam I'm adam


Sample Output

hcum ekam ll'ew kniht t'nod I ,ylknarF
.emehcs siht fo tuo yenom
mada m'I madam

简单题。。 借助stl库 algorithm中 reverse函数。
读取用到gets(char*) 含空白符的整行读取 getchar 读取单字符。

#include<iostream>
using namespace std;
#include<cstring>
#include<algorithm>
#include<stdio.h>

int main()
{
string s;
char src[70];
int n;
cin>>n;
getchar(); //把换行符读走,下面按行读取
for(int i=0;i<n;i++)
{
gets(src);
s = string(src);
reverse(s.begin(),s.end());
cout<<s.c_str()<<endl;;
}

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值