ZOJ-1383 二进制找1

1383: 给一整数,输出二进制下1的位置。
The position of the least significant bit is 0

Sample Input

1
13


Sample Output

0 2 3


由于从最小端开始逆序输出,因此采用取模的方法。
由于不知道最后一位什么时候输出,因此空格放在头部判断。

#include<stdio.h>
#include<iostream>
using namespace std;

int main()
{
int d;
int n;
int pos=0;
bool ishead=true;

cin>>d;
for(int i=0;i<d;i++)
{
cin>>n;
ishead=true;
pos=0;
while(n)
{
if(n%2==1)
{
if(ishead)
ishead=false;
else
cout<<" ";
cout<<pos;
}
n/=2;
pos++;
}
cout<<endl;
}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值