ZOJ-1049 几何算数题

1049:选一坐标点建房。河水淹没区域是半圆形,每年扩大50平方英里。问几年能淹到房子。


[img]http://dl.iteye.com/upload/attachment/535604/78514a91-d048-3317-a580-0405323481b6.gif[/img]


Sample Input:

2
1.0 1.0
25.0 0.0


Sample Output:

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.


简单题。就是比较圆半径和点到原点距离。

#include<stdio.h>
#include<iostream>
using namespace std;

#define PI 3.1415927

int main()
{
int N;
double x;
double y;
int area;
int k;
cin>>N;
for(int i=1;i<=N;i++)
{
cin>>x;
cin>>y;
area=0;
//半圆面积1/2*PI*r*r
for(k=0;;k++)
{
if(2*area/PI>x*x+y*y)
break;
else
area+=50;
}
printf("Property %d: This property will begin eroding in year %d.\n",i,k);
}
printf("END OF OUTPUT.\n");

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值