ZOJ Problem Set - 1049

【【数学题】】


【题目】

I Think I Need a Houseboat

Time Limit: 1 Second      Memory Limit: 32768 KB

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

Input Format:

The first line of input will be a positive integer indicating how many data sets will be included (N).

Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.


Output Format:

For each data set, a single line of output should appear. This line should take the form of:

��Property N: This property will begin eroding in year Z.��

Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer.

After the last data set, this should print out ��END OF OUTPUT.��

Notes:

1. No property will appear exactly on the semicircle boundary: it will either be inside or outside.

2. This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.

3. All locations are given in miles.

Sample Input:

2
1.0 1.0
25.0 0.0


Sample Output:

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.


Source: Mid-Atlantic USA 2001


【题意说明】Fred要在海岸边造一屋子,海岸线边的土地以每年50平方英里的速率被侵蚀,侵蚀的面积为一个逐年扩大的半圆。假设以半圆的圆心为坐标原点,给出Fred的屋子坐标(x, y)(单位:英里),计算出约几年后屋子所在土地被侵蚀。

【解答】

(一)分析:逐年计算被侵蚀的土地面积S=50n(n为年限),可得侵蚀的半圆土地的半径r=(2S/π)^(1/2),从而计算屋子离圆心的距离d=(x^2+y^2)^(1/2)如果小于r则表示在第n年时屋子已经被侵蚀,反之则未被侵蚀。

(二)代码:

#include<iostream>
#include<cmath>
using namespace std;
bool Judge(double x,double y,double r)
{
	double dis;
	dis=sqrt(x*x+y*y);
	if(dis<r)
		return true;
	else return false;
}
int main()
{
	int n,i,year;
	double x,y,r;
	const double PI=3.141592653;
	while(cin>>n)
	{
		for(i=1;i<=n;i++)
		{
			cin>>x>>y;
			year=1;
			while(true)
			{
				r=sqrt(100.0*(double)year/PI);
				if(Judge(x,y,r))
				{
					cout<<"Property "<<i<<": This property will begin eroding in year "<<year<<"."<<endl;
					break;
				}
				year++;
			}
		}
		cout<<"END OF OUTPUT."<<endl;
	}
        return 0;
}
//Accepted


(解于2009/10)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值