pat-1008 Elevator

1008:
电梯上升一层6秒,下降4秒,停留5秒。给出请求序列求总时间。

Sample Input:
3 2 3 1
Sample Output:
41



#include<iostream>
using namespace std;

int main()
{
int curr=0;
int next;
int n;
int time=0;

cin>>n;
while(n--)
{
cin>>next;
if(next>curr)
time+=(next-curr)*6;
else if(next<curr)
time+=(curr-next)*4;
time+=5;
curr = next;
}

cout<<time;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值