PAT甲级-1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:
For each test case, print the total time on a single line.

Sample Input:
3 2 3 1

Sample Output:
41

题目意思大概是有一个需求列表有N个正数,这些数表示电梯会在哪一层停,电梯上升一层花费6秒,下降一层花费4秒,在一层停留5秒,走完列表中的几层需要多少秒,输出结果。
解题思路:要注意的是刚开始电梯在0层,并且最后完成电梯不需要再返回0层。那我们应该就需要一个变量来记录此时电梯所在层数,并挨个和列表中的数比较,如果此时的层数小于列表中的那么就是上升,反之下降,相等则等待,并设一个变量,把每次的时间累加到变量里,不要忘记加每次停留的时间,最后输出变量即可。

#include<iostream>
using namespace std;

int main()
{
	int N,gowhere=0,cur=0,time=0;//gowhere为要去的楼层,cur为当前楼层
	cin>>N;
	while(N--)
	{
		cin>>gowhere;
		if(gowhere>cur) time+=(gowhere-cur)*6+5;
		else if(gowhere<cur) time+=(cur-gowhere)*4+5;
		else time+=5;
		cur=gowhere;
	}
	cout<<time;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值