ZOJ-3174 平方数

3174:月份和天等于年份后三位或后两位的平方根,这样的一天定义为Square Root Day

给出起始年份和终止年份,求符合的有多少个。

Sample Input

2
2009 2009
81 100

Sample Output

1
2


思路:将12内平方存数组。遍历统计即可。


#include<iostream>
using namespace std;
#include<memory.h>
int ref[1000];

int main()
{
memset(ref,0,sizeof(ref));
for(int i=1;i<=12;i++)
ref[i*i]=i;

int ncase;
int start;
int end;
int count;
cin>>ncase;
while(ncase--)
{
cin>>start;
cin>>end;
count = 0;
for(int i=start;i<=end;i++)
{
if(ref[i%100]!=0||ref[i%1000]!=0)
count++;
}
cout<<count<<endl;
}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值