hdu3336 Count the string(kmp字符串比较)

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”
The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input

1
4
abab

Sample Output

6
#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
using namespace std;

#define M 200020
int ne[M];

void GetNext(char *a, int n)
{
    int i = 0, j = -1;
    ne[0] = -1;
    while (i < n)
    {
        if(j == -1 || a[i] == a[j]){
            ne[++i] = ++j;
        }
        else j = ne[j];//回溯至上一个
    }
}

int main()
{
    int t, l, i;
    scanf("%d", &t);
    while(t--)
    {
        char a[M];
        int s = 0;
        scanf("%d", &l);
        scanf("%s", &a);
        GetNext(a, l);
        s += l + ne[l];     //l表示有多少个前缀,因为他在计算前缀出现的次数时一定会包含它本身。ne[l]表示最长重复部分的长度,因为该前缀的每一个前缀一定会重复一次,所以重复ne[l]次
        for(i = 0; i < l; i++){
            if(ne[i] > 0 && ne[i + 1] - ne[i] != 1)
                s += ne[i];       //寻找ne的值激变前的值,该值就代表该字符前的最大前缀的长度,即该最大前缀中每个前缀重复的次数总数
        }
        s = s % 10007;
        printf("%d\n", s);
    }
    return 0;
}

真吓人,我啥时候思路也能这么简化就好了,大佬就是大佬,我的思路t的我难受~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值