Agri-Net

Agri-Net
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28

解题思路:这一道题是可以直接使用Prim算法进行解答
prim算法:1.先在所有点中任意选择一个点a构造生成树并创建记录这个生成树和其他点距离的数组dis[],如果点a与有些点没有直接相连的边,则设其无穷大,同时用book[]数组记录点a已经加入生成树
2.从dis[]数组中选择距离生成树最小的点加入生成树,因为有新的点加入到生成树,所以可能原来的生成树通过这个新加入的点缩短了和其他未加入点的距离,所以我们要通过这个点更新dis[]数组。
3.将2步骤循环至所有断电==顶点加入生成树为止

#include<stdio.h>
int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		int book[101] = { 0 };
		int e[101][101];
		int dis[101];
		int inf = 99999999, min;
		int i, j, count = 0, sum = 0;
		for (i = 1; i <= n; i++)
			for (j = 1; j <= n; j++)
			{
				scanf("%d", &e[i][j]);
				if (i == 1)
				{
					dis[j] = e[i][j];
				}
			}
		book[1] = 1;
		count++;
		while (count < n)
		{
			min = inf;
			for (i = 1; i <= n; i++)
			{
				if (book[i] == 0 && dis[i] < min)
				{
					min = dis[i];
					j = i;
				}
			}
			book[j] = 1;
			count++;
			sum += dis[j];
			for (i = 1; i <= n; i++)
			{
				if (book[i] == 0 && dis[i] > e[j][i])
					dis[i] = e[j][i];
			}
		}
		printf("%d\n", sum);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值