POJ水题1083区间重叠问题

1083  区间重叠问题  
    输入多个区间,每次可以消掉任意不重叠的区间,最少要消几次?
    等价于选择某个点,最多有几个区间覆盖该点?
法一:按区间存储,按左值递增,右值递增排序,扫描一遍。O(n2) 
法二:用数组存储每个点所占的次数,则答案为最大值。(why????画图。。。????)
法三:区间离散成点,按点的大小排序,扫描一遍,遇起点+1,遇终点-1,最大值即为答案。

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30
法一:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
struct P{
    int x,y;
};
P line[205];
bool judge[205];
bool cmp(P x,P y){
    if(x.x!=y.x)
        return x.x<y.x;
    return x.y<y.y;
}
int main () {
    int t,n,x,y;
    cin>>t;
    while(t--){
        cin>>n;
        for(int i=0;i<n;++i)
        {
            scanf("%d%d",&x,&y);
            if(x>y) swap(x,y);
            line[i].x=(x+1)>>1;
            line[i].y=(y+1)>>1;
        }
        sort(line,line+n,cmp);
        int ans=0;
        memset(judge,0,sizeof(judge));
        for(int i=0;i<n;++i)
            if(!judge[i])
            {
                ans++;
                judge[i]=1;
                int mid=i;
                for(int j=i+1;j<n;++j)
                if(!judge[j]&&line[j].x>line[mid].y){
                    judge[j]=1;
                    mid=j;
                }
            }
        cout<<ans*10<<endl;
    }
    return 0;
}
法二:

#include <stdio.h>
#include <string.h>
int room[201];
int main()
{
    int m,n,i,j;
    int a,b,t;
    int maxx;
    while(scanf("%d",&m)!=EOF)
    {
        while(m--)
        {
            scanf("%d",&n);
            memset(room,0,sizeof(room));
            maxx=0;
            for(i=0;i<n;i++)
            {
                scanf("%d %d",&a,&b);
                if(a>b)
		    swap(a,b);
                for(j=(a+1)/2;j<(b+1)/2+1;j++)
                {
                    room[j]++;
                    maxx=max(room[j],maxx);
                }
            }
            printf("%d\n",maxx*10);
        }
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值