POJ 1029



Description

The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting:
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan,
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

Sample Output

3

Source

思路分析:

辨别假币,当是真币时就使用-1进行标注,当遇到天平不平衡时,原先相等的硬币标注为-1的,就保持不变,没有遇到硬币为-1的,就进行标注为1,最后判断哪个是1 的则为假币。

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int N,K;
    char c;
    int left[100],right[100];
    int a[100],b[100];
    int answer,count=0;
    while(cin>>N>>K)
    {
        int number;
        int i;
        while(K--)
        {
        cin>>number;
        for(i=0;i<number;i++)
            cin>>left[i];
        for(i=0;i<number;i++)
            cin>>right[i];
        cin>>c;
        if(c=='=')
        {
            for(i=0;i<number;i++)
            {
               a[right[i]]=a[left[i]]=1;
            }
        }
       else
       {
           for(i=0;i<number;i++)
           {
               a[right[i]]=a[left[i]]=-1;
           }
       }
        }
         for (int i = 1; i<=N; i++)
         {
             if (a[i]==-1)
             {
                 answer = i;
                 count++;
             }
             if(count==2) break;
         }
         if(count!=1)
            cout << "0" << endl;
         else
            cout <<answer<< endl;
    }
}

虽然结果是正确的,但是提交后还是WA,是想的方向错了?忽略了硬币的重量,我的程序只是适用像多个相等的例子,所以对于多个不等的就会出现错误,不能进行多个实验,我想这是出现WA的原因。

上网查看了许多的思路,也借鉴 了一些。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    //freopen("input.txt","r",stdin);///从文件中读取
    int N,K;
    char c;
    int left[1000],right[1000];
    int a[1000],b[1000];
    int appear=0,answer,count=0;
    cin>>N>>K;
        int number=0;
        int i;
        while(K--)
        {
        cin>>number;
        for(i=0;i<number;i++)
            cin>>left[i];
        for(i=0;i<number;i++)
            cin>>right[i];
        cin>>c;
        if(c=='=')
        {
            for(i=0;i<number;i++)
            {
               a[right[i]]=a[left[i]]=b[right[i]]=b[left[i]]=-1;
            }
        }
       else if(c=='<')
       {
           appear++;
           for(i=0;i<number;i++)
           {
               if(a[left[i]]!=-1) a[left[i]]++;
               if(a[right[i]]!=-1) b[right[i]]++;
           }
       }
       else
       {
           appear++;
          for(i=0;i<number;i++)
           {
               if(a[left[i]]!=-1) b[left[i]]++;
               if(a[right[i]]!=-1) a[right[i]]++;
           }
       }
        }
         for (int i = 1; i<=N; i++)
         {
             if (a[i]==appear || b[i]==appear)
             {
                 answer = i;
                 count++;
             }
             if(count==2) break;
         }
         if(count!=1)
            cout << "0" << endl;
         else
            cout <<answer<< endl;

}https://www.cnblogs.com/zyb993963526/p/6515377.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值