hyperledger-fabric的Error: got unexpected status: BAD_REQUEST错误(执行Building Your First Network时)

环境:阿里云ECS centos7

问题一:

今天在看hyperledger-fabric文档时,看到有Building Your First Network就顺便试了一下;但是在执行 ./byfn.sh up时出现了下面的错误:

Error: got unexpected status: BAD_REQUEST -- error authorizing update: error validating DeltaSet: policy for [Group]  /Channel/Application not satisfied: Failed to reach implicit threshold of 1 sub-policies, required 1 remaining

导致:

!!!!!!!!!!!!!!! Channel creation failed !!!!!!!!!!!!!!!!

========= ERROR !!! FAILED to execute End-2-End Scenario ===========


解决方法: 执行 ./byfn.sh -m restart -c mychannel 就可以执行成功了

参考(tang-xun用户的回答):https://github.com/yeasy/docker-compose-files/issues/51


阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页