sicily 1001. Alphacode

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: "Let's just use a very simple code: We'll assign `A' the code word 1, `B' will be 2, and so on down to `Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the word `BEAN' encoded as 25114. You could decode that in many different ways!" Alice: "Sure you could, but what words would you get? Other than `BEAN', you'd get `BEAAD', `YAAD', `YAN', `YKD' and `BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN' anyway?" Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense." Alice: "How many different decodings?" Bob: "Jillions!" For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0' will terminate the input and should not be processed

Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114
1111111111
3333333333
0

Sample Output

6
89
1

题目分析:这是一道动态规划的题目。题目意思就是,给出一个字符串的数字,然后,根据这个数字字符串编码成字母,数字’1‘对应’A‘  ’2‘对应’B‘ 以此类推 ‘26’对应‘Z ’

题目要求: 求出所有的可能编码情况。具体意思可以看题目介绍

参考代码:

 

#include <iostream>
#include <stdio.h>
#include <queue>
#include <cstring>
#include <vector>
#include <memory.h>
using namespace std;

int main()
{
	char str[1000];
	while (scanf("%s", str) && str[0] != '0')
	{
		int len = strlen(str);
		long int dp[len + 9];
		memset(dp, 0, sizeof(dp));
		dp[0] = 1;
		dp[1] = 1;
		for (int i = 2; i <= len; ++ i)
		{
			if (str[i - 1] == '0')
			{
				dp[i] = dp[i - 2];
			}
			else
			{
				dp[i] = dp[i - 1];
				if (str[i - 2] == '1')
				{
					dp[i] = dp[i] + dp[i - 2];
				}
				else if (str[i - 2] == '2' && str[i - 1] >= '1' && str[i - 1] <= '6')
				{
					dp[i] = dp[i] + dp[i - 2];
				}
			}
		}
		printf("%ld\n", dp[len]);
		
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值