Crossing River

描述
A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

输入

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.
输出
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
样例输入
1
4
1 2 5 10
样例输出
17
题解
#include <cstdio>
#include <iostream>
#include <algorithm>
int i,j,k,l,m,n,p,o,ans;
int a[10001];
int main()
{
	scanf("%d",&p);
	for (o=1;o<=p;o++)
	{
		scanf("%d",&n);
		for (i=1;i<=n;i++)
		scanf("%d",&a[i]);
		std::sort(a+1,a+n+1);
		ans=0;
		while (n>3)
		{
			k=a[2]*2+a[1]+a[n];//先将第二快的载回来,最快的划船回去,第二慢的和最慢的回来,第二慢的划船过去 
			l=a[n]+a[1]*2+a[n-1];//最快的和最慢的回来,最快的划船回去,最快的和第二慢的回来,第二慢的划船回去 
			if (k>l) ans=ans+l;
			else ans=ans+k;
			n=n-2;
		}
		if (n==3) ans=ans+a[1]+a[2]+a[3];//先将最慢的回来,最快的划船回去,将第二慢的载回来 
		else
		if (n==2) ans=ans+a[2];//剩下的两个人乘船回来 
		else ans=ans+a[1];//自己乘船 
		printf("%d\n",ans);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值