1010.Number Triangles

题目大意:给出数字金字塔,找出从上到下的一条路,使得总和最大,且只能从上往左下或右下走。
Description

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

 

Input

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

Output

A single line containing the largest sum using the traversal specified.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Huge input, scanf is recommended if you are using C++.

Source
USACO
// 1010_NumberTriangles.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"

#include<iostream>
#include<string.h>
//#include<math.h>

using namespace std;

int str[1100][1100], dir[1010][1010];

int max(int a, int b)
{
	return (a > b) ? a : b;
}

int main()
{
	int n, i, j;

	while (cin >> n)
	{
		for (i = 1; i <= n; i++)
		{
			for (j = 1; j <= i; j++)
			{
				cin >> str[i][j];
			}
		}
		memset(dir, 0, sizeof(dir));

		for (i = n; i >= 1; i--)
		{
			for (j = 1; j <= i; j++)
			{
				dir[i][j] = max(dir[i + 1][j], dir[i + 1][j + 1]) + str[i][j]; //从底层开始寻找最大的数据
			}
		}
		cout << dir[1][1] << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值