字符统计(函数实现)

编写一个函数,统计一个字符串中字母、数字和空格的个数。使用全局变量存放字母和数字个数,函数返回值是空格个数


#include <stdio.h>
#include <string.h>
#include <math.h>

int nL=0, nN=0;

int statistics(char *s)
{
    _______________________
}

int main()
{
    char s[81];
    int nS;
    gets(s);
    nS = statistics(s);

    printf("%d %d %d\n", nL, nN, nS);
    return 0;
}
 

输入格式

输入一行字符,以'\n'符结束

输出格式

统计结果

输入样例

Ab 45

输出样例

2 2 1
#include<stdio.h>
#include<string.h>
#include<math.h> 

int nL=0,nN=0;

int statistics(char *s)
{
	int nS=0;
	for(int i=0;s[i]!='\0';i++)
	{
		if(s[i]>='0'&&s[i]<='9') nN++;
		if(s[i]>='a'&&s[i]<='z'||s[i]>='A'&&s[i]<='Z') nL++;
		if(s[i]==' ') nS++;
	}
	return nS;
}

int main()
{
    char s[81];
    int nS;
    gets(s);
    nS=statistics(s);
    
    printf("%d %d %d\n",nL,nN,nS);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值