hdu 4045 Machine scheduling 斯特林数+插板法

18 篇文章 0 订阅
4 篇文章 0 订阅

Machine scheduling

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1069    Accepted Submission(s): 400


Problem Description
A Baidu’s engineer needs to analyze and process large amount of data on machines every day. The machines are labeled from 1 to n. On each day, the engineer chooses r machines to process data. He allocates the r machines to no more than m groups ,and if the difference of 2 machines' labels are less than k,they can not work in the same day. Otherwise the two machines will not work properly. That is to say, the machines labeled with 1 and k+1 can work in the same day while those labeled with 1 and k should not work in the same day. Due to some unknown reasons, the engineer should not choose the allocation scheme the same as that on some previous day. otherwise all the machines need to be initialized again. As you know, the initialization will take a long time and a lot of efforts. Can you tell the engineer the maximum days that he can use these machines continuously without re-initialization.
 

Input
Input end with EOF.
Input will be four integers n,r,k,m.We assume that they are all between 1 and 1000.
 

Output
Output the maxmium days modulo 1000000007.
 

Sample Input
  
  
5 2 3 2
 

Sample Output
  
  
6
Hint
Sample input means you can choose 1 and 4,1 and 5,2 and 5 in the same day. And you can make the machines in the same group or in the different group. So you got 6 schemes. 1 and 4 in same group,1 and 4 in different groups. 1 and 5 in same group,1 and 5 in different groups. 2 and 5 in same group,2 and 5 in different groups. We assume 1 in a group and 4 in b group is the same as 1 in b group and 4 in a group.
 传送门:http://blog.csdn.net/acm_cxlove/article/details/7857785
代码:
#include <stdio.h>
#define MOD 1000000007
int c[2010][2001] = {1} , stir[1010][1010] = {1} ;
int min(int a , int b)
{
	return a>b?b:a ;
}
int main()
{
	for(int i = 0 ; i <= 2000 ; ++i)
	{
		c[i][0] = c[i][i] = 1 ;
		for(int j = 1 ; j < i ; ++j)
		{
			c[i][j] = (c[i-1][j-1]+c[i-1][j])%MOD ;
		}
	}
	for(int i = 1 ; i <= 1000 ; ++i)
	{
		stir[i][0] = 0 ;
		stir[i][i] = 1 ;
		for(int j = 1 ; j < i ; ++j)
		{
			stir[i][j] = ((long long)j*stir[i-1][j]+stir[i-1][j-1])%MOD ;
		}
	}
	int n,r,k,m ;
	while(~scanf("%d%d%d%d",&n,&r,&k,&m))
	{
		int rem = n-(r-1)*k-1 ;
		if(rem<0)
		{
			puts("0") ;
		}
		else
		{
			long long sum = 0 ;
			int len = min(r,m) ;
			for(int i = 1 ; i <= len ; ++i)
			{
				sum = (sum+stir[r][i])%MOD ;
			}
			printf("%d\n",c[rem+r][r]*sum%MOD) ;
		}
	}
	return 0 ;
}

与君共勉
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值