poj1258 Agri-Net 最小生成树水题

50 篇文章 0 订阅
24 篇文章 0 订阅
Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 55019 Accepted: 22821

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28


Physically, they are limited in length to 80 characters, so some lines continue onto others. 

大家可能对这句话有些疑惑,它的意思的应该是一行的数据不超过80个字符,超过的另起一行。

对于这道题本身可能没什么好讲的,就是一道赤裸裸的最小生成树。可prim,可Kruskal,对与想学习数据结构的同学来说,这道题算是一道不错的练手题。

prim算法:

#include <stdio.h>
#include <string.h>
const int INF = 110000;
const int MAX = 110;
int g[MAX][MAX];
bool visited[MAX] ;

void init()
{
	memset(visited,false , sizeof(bool)*MAX) ;
	for(int i = 0 ; i < MAX ; ++i)
	{
		for(int j = 0 ; j < MAX ; ++j)
			g[i][j] = INF ;
	}
}

int prim(int n)
{
	
	int lowCost[MAX] ;
	for(int i = 0 ; i < n ; ++i)
	{
		lowCost[i] = g[0][i] ;
	}
	visited[0] = true ;
	int sum = 0 ;
	for(int i = 0 ; i < n-1 ; ++i)
	{
		int min = INF , index ;
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && lowCost[j] < min)
			{
				min = lowCost[j] ;
				index = j;
			}
		}
		visited[index] = true ;
		sum += min ;
		
		for(int j = 0 ; j < n ; ++j)
		{
			if(!visited[j] && lowCost[j]>g[index][j])
			{
				lowCost[j] = g[index][j] ;
			}
		}
	}
	return sum ;
}

int main()
{
	int n ;
	while(~scanf("%d",&n))
	{
		init();
		for(int i = 0 ; i<n ; ++i)
		{
			for(int j = 0 ; j<n ; ++j)
			{
				scanf("%d",&(g[i][j])) ;
			}
		}
		printf("%d\n",prim(n)) ;
	}
	
	return 0 ;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值