unable to resolve dependency for:xxx

Android中遇到的坑 专栏收录该内容
5 篇文章 0 订阅

在build project 之后,报unable to resolve dependency for:xxx的错误

这个是添加依赖的过程中报错,无法添加依赖。

先用通用方法检查一下

0.请先确认clean Project过(有时候可能还需要清除Android Studio的缓存)

Clean Project的具体方法: Build -->Clean Project (如果无法Clean,请直接进入项目中,app文件夹,手动删除build文件即可)

清除Android Studio缓存的方法:File --> Invalidate Caches / Restart -->点击 Invalidate and Restart

上面两个方法,可以解决一般 编译文件造成的问题。

或许是你的Android Studio离线模式(不适用于AS 4.0+)

1.如果是刚安装Android Studio,先检测是否为离线模式。离线模式当然没有网络,当然就无法下载依赖了

检查 File-->Settings...-->Build, Execution, Deployment-->Gradle-->取消Offline work的勾选

再试一次

如果还不行,再往下看

或许是你无法连接到仓库

2.如果是大陆的网络,经常会有波动。因为我们下载依赖,需要【科学】上网,所以,我们可以选择阿里镜像。这样就不会受到网络波动的影响了

工程目录 app-->build.gradle 在android{..}下 添加下列代码,如果已有,请覆盖修改

allprojects {
    repositories {
        jcenter()
        maven { url 'http://maven.aliyun.com/nexus/content/groups/public/' }
    }
}
buildscript {
    repositories {
        maven{ url 'http://maven.aliyun.com/nexus/content/groups/public/'}
    }
}

再试一次

如果还不行,再往下看

如果是旧版AS升级到3.0的AS

3.如果是Android Studio 3.0,可能需要删除一些东西。因为AS3.0 对lambda 表达式支持,不需要使用第三方库了

1) app-->build.gradle中的  apply plugin: 'me.tatarka.retrolambda 需要删除,

dependencies中的:

releaseCompile project(path: ':library', configuration: 'release')

debugCompile project(path: ':library', configuration: 'debug')

但是,将library删除之后,你还需要将其在project strcture中重新导入

2) library的build.gradle中  apply plugin: 'me.tatarka.retrolambda'    删了

3) 删除project的build.gradle  中的:classpath 'me.tatarka:gradle-retrolambda:3.3.1'

4) 最后需要将gradle.properties文件中添加android.enableAapt2=false ,关闭关闭aapt2的编译。

再试一次

如果还不行....

请给我留言

一起学习进步

相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值