Pre- and Post-order Traversals

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line "Yes" if the tree is unique, or "No" if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:
7
1 2 3 4 6 7 5
2 6 7 4 5 3 1
Sample Output 1:
Yes
2 1 6 4 7 3 5
Sample Input 2:
4
1 2 3 4
2 4 3 1
Sample Output 2:
No
2 1 3 4
该题目大意是根据二叉树的前序和后序确定中序遍历。该题目的关键是要了解三种遍历的特点。具体到这题来说,前序遍历的第一个元素和后序遍历的最后一个元素是根元素,而且对于超过3个元素的序列,前序遍历的第二个元素一定是左子树的根元素,那么后序遍历的该元素和其左边的元素都是左子树。当序列只有一个元素时,就是根元素。无法确定的情况是两个元素的情况。此时第二个元素可能是左子树,也可能是右子树。知道了这些,就可以愉快的用递归来解决问题了。
#include <stdio.h>
#include <stdlib.h>
#include <vector>
using namespace std;
vector <int> x(40);//前序遍历
vector <int> y(40);//后序遍历
vector <int> z(40);//中序遍历
bool is=true;
void find(int e,int a,int b,int c,int d);//这里的 a,b,c,d 分别是前序和后序的左标和右标
int main() {
	int a;
	scanf("%d", &a);
	for(int i=0;i<a;i++)
		scanf("%d",&x[i]);
	for(int i=0;i<a;i++)
	    scanf("%d",&y[i]);
	find(0,0,a-1,0,a-1); 
	if(is==true)
		printf("Yes\n");
	if(is==false)
		printf("No\n");
	for(int i=0;i<a;i++){
		if(i==a-1){
			printf("%d\n",z[i]);
			continue;
		}

		printf("%d ",z[i]);
	}
	return 0;
}

void find(int e,int a,int b,int c,int d)
{
	if(b-a==1){  //只有两个元素时
		is=false;
		z[e]=x[c];
		z[e+1]=x[d];
		return;
	}
	if(b-a==0)   //只有一个元素时
	{
		z[e]=y[a];
		return;
	}
	int a1=x[c+1];
	int b1;
	for(int i=a;i<b;i++){
		if(y[i]==a1){
			b1=i;
			break;
		}
	}
	z[e+b1-a+1]=x[c];
	find(e,a,b1,c+1,c+1+b1-a);
	if(b1+1!=b)            //这个条件不能不写,不然在右子树为空的时候向量会越界,出现段错误
	    find(e+b1-a+1+1,b1+1,b-1,c+b1-a+2,d);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值