HDOJ 4006The kth great number 解题报告

2 篇文章 0 订阅
1 篇文章 0 订阅

链接:http://acm.hdu.edu.cn/showproblem.php?pid=4006

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input

8 3

I 1

I 2

I 3

Q

I 5

Q

I 4

Q

Sample Output

1

2

3


考查优先队列,由于题目要找到第k大的数,所以构建个大小为k的优先队列,如果队列大小以达到k,再向队

列添加元素时将最小的元素移出队列。注意,队列默认是值大的先出列,所以用语句priority_queue<int,

vector<int>,greater<int> > q;定义优先队列,从而改变出队列的顺序。



#include<cstdio>
#include<queue>
#include<iostream>
using namespace std;
int main()
{
    int n,k,t;
    char x;
    int temp;
    while(scanf("%d%d\n",&n,&k)!=EOF)
    {
        priority_queue<int,vector<int>,greater<int> > q;
        for(t=1;t<=n;t++)
        {
        scanf("%c",&x);
        if(x=='I')
        {
            scanf("%d\n",&temp);
            if(q.size()<k) q.push(temp);
            else
            {
                q.push(temp);
                q.pop();
            }
        }
        else{scanf("%c",&x);printf("%d\n",q.top());}
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值