Monkey and Banana(经典DP杭电1609)

题目:

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input Specification

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output Specification

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:给你M种长方体,计算最高能堆多高。

要求位于上面的长方体的长要大于下面长方体的长,上面长方体的宽大于下面长方体的宽。

解题:1.先列出所有长方体的情况,每种长方体有6种摆法,通过长宽排序,减置三种情况。

           2.将所有长方体按先长后宽由小到大进行排序,以便进行顺序堆叠。

           3.然后j到i之间的长方体进行堆叠(遍历了所有可堆叠的情况),记录下最大的高度,

           4.每i层之前的最大高度加上本层高度作为下次比较的高度,并记录下来。
           5.输出所有堆叠高度里面最高的.

#include <iostream>
#include <algorithm>
using namespace std;
struct Cuboid
{
    int l,w,h;
}cd[100];
int dp[100];
// sort函数的比较规则
bool cmp( Cuboid cod1,Cuboid cod2 )
{
    if( cod1.l==cod2.l )
    return cod1.w<cod2.w;
    return cod1.l<cod2.l;
}
int main()
{
    int i,j,n,len,t_num=1;
    int z1,z2,z3;
    while( cin>>n && n )
    {
        len=0;
        // 每组数都可以变换为3种长方体
        for(i=0;i<n;++i)
        {
            cin>>z1>>z2>>z3;
            cd[len].h=z1,cd[len].l=z2>z3?z2:z3,cd[len++].w=z2>z3?z3:z2;
            cd[len].h=z2,cd[len].l=z1>z3?z1:z3,cd[len++].w=z1>z3?z3:z1;
            cd[len].h=z3,cd[len].l=z1>z2?z1:z2,cd[len++].w=z1>z2?z2:z1;
        }
        //按规则排序 
        sort(cd,cd+len,cmp);
        dp[0]=cd[0].h;
        int max_h;
        for(i=1;i<len;++i)
        {                        
            max_h=0;
            for( j=0;j<i;++j )    //由j到i进行堆放,找出第i个之前的最大高度
            {
                if( cd[j].l<cd[i].l && cd[j].w<cd[i].w )
                    max_h=max_h>dp[j]?max_h:dp[j];
            }
            dp[i]=cd[i].h+max_h;  //每i层之前的最大高度加上本层高度作为下次比较的高度
        }
        //输出dp数组中最大的高度
        cout<<"Case "<<t_num++<<": maximum height = "<<*max_element(dp,dp+len)<<endl;
    }
    return 0;
}

 

 

  • 5
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值