Switch game

描述

There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).

输入

Each test case contains only a number n ( 0< n<= 10^5) in a line.

输出

Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).

样例输入

1
5

样例输出

1

0


先把这些灯标上号,1 2 3 4 5 6 7 8 ……无穷
首先全是关的,也就是全是0
第一次操作 ,标号是1的倍数,全都变成相反的状态,也就是全变成1.。
第二次操作 ,标号是2的倍数,全都变成相反的状态,你可以看下,2 4 6……变成了0.。。
第三次操作 ,标号是3的倍数,全都变成相反的状态,你可以看下,3 6 9……

他问你 N 号台灯最后 变成了 什么状态,
例如 1号灯,最后变成了1,不管多少次操作都是1.。
例如 5号灯 最后变成了0,不管多少次操作都是0.。

当操作次数大于N的时候 N的状态就不会改变了,因为N不会是M(M>N)的倍数。。
 
 
 
 
思路很简单就是求n有几个约数(包括1和自身)如果有奇数个约数,则是变奇数次,结果也就是1;否则为0



#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
#include<cmath>
using namespace std;
int main()
{
    int n,k;
    while(scanf("%d",&n)!=EOF)
    {
        k=0;
        for(int i=1;i<=n;i++)
        {
            if(n%i==0)
                k++;
        }
        if(k%2==0)
          printf("0\n");
        else
            printf("1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值