hdu 1150 最小点覆盖 Machine Schedule

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine’s working mode from time to time, but unfortunately, the machine’s working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
Output
The output should be one integer per line, which means the minimal times of restarting machine.
Sample Input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
Sample Output
3

给n个任务,每个任务可以用 机器A 的进程x 或者机器B 的进程y 运行,机器的每次换进程都要重启一次,问最少的重启次数,把 每个任务的两个进程连接起来,每条线都要有一个端点被选择,问最少的点覆盖所有的线,就是最小点覆盖,最小点覆盖=最大匹配数。因为初始是0,所以0任务的线不用连。。。

#include <bits/stdc++.h>
using namespace std;

const int N = 1010;
int n,m,f[1010];
bool vis[1010];
vector<int> v[1010];


int dfs(int i)
{
    vis[i]=1;
    for(int j=0;j<v[i].size();j++)
    {
        if(f[v[i][j]]==-1||(!vis[ f[v[i][j]] ]&&dfs(f[v[i][j]])))
        {
            f[v[i][j]]=i;
            return 1;
        }
    }

    return 0;

}

int main()
{
    int k,m,n,d;
    while(scanf("%d",&n),n)
    {

        scanf("%d%d",&m,&k);
        memset(f,-1,sizeof(f));
        for(int i=0;i<=n;i++)
            v[i].clear();
        for(int i=0;i<k;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(b>0&&c>0)
                v[b].push_back(c);
        }
        int cnt=0;
        for(int i=1;i<=n;i++){
        //不需要判断 f[i]!=-1 因为是两个集合,所以只需要处理左边就好
        //用上的话就是处理了同一个集合。
                memset(vis,0,sizeof(vis));
                cnt+=dfs(i);
        }
        printf("%d\n",cnt);
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值