课程练习四-problemR

Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:<br>1) Extract the common characteristics from the incoming email.<br>2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.<br><br>We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:<br><br>a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so<br>relationships (other than the one between X and Y) need to be created if they are not present at the moment.<br><br>b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.<br><br>Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.<br>Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.<br>Each test case starts with two integers, N and M (1 ≤ N ≤ 10<sup>5</sup> , 1 ≤ M ≤ 10<sup>6</sup>), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.<br>Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
  
  
Case #1: 3 Case #2: 2
 


题意: 

有N封邮件, 然后又两种操作,如果是M X Y , 表示X和Y是相同的邮件。 如果是S X,那么表示对X的判断是错误的,X是不属于X当前所在的那个集合,要把X分离出来,让X变成单独的一个。

思路: 

使用了节点数的的下标+n作为父节点,这个位置只是标记父节点,并没其他含义,等于是虚拟的节点。
这样当删除一个节点时只用从这个节点中拿出来让其父节点重新放在一个虚拟的位置,即下标从n+n开始向后找。
最后是查找独立特点的集合。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#define MAXNUM1 100005
#define MAXNUM2 1000005

using namespace std;
int father[MAXNUM1*2+MAXNUM2],num[MAXNUM1];

int find_father(int a)
{
    if(father[a]==a)return a;
    else return father[a]=find_father(father[a]);
}
int main()
{
    int n,m,ca,x,y,total;
    char op[3];
    ca = 0;
    while(scanf("%d%d",&n,&m)!=EOF&&n)
    {
        for(int i=0;i<n;i++)father[i]=i+n;
        for(int i=n;i<=n+n+m;i++)father[i]=i;
        total = n+n;
        for(int t=0;t<m;t++)
        {
            scanf("%s",op);
            if(op[0]=='M')
            {
                scanf("%d%d",&x,&y);
                int rx = find_father(x);
                int ry = find_father(y);
                if(rx!=ry)father[rx]=ry;
            }else{
                scanf("%d",&x);
                father[x] = total++;
            }
        }
        for(int i = 0; i < n; i++)num[i] = find_father(i);
        sort(num,num+n);
        int ans=1;
        for(int i = 1; i < n;i++)
        if(num[i]!=num[i-1])ans++;
        printf("Case #%d: %d\n",++ca,ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值