短名字

短名字

0.总结

Get to the key point firstly, the article comes from LawsonAbs!


1.题意

题意链接

Bob is making a video conference software. Whenever a new person joins the conference, Bob displays the person’s name in the interface.

However, displaying full name is tedious and takes much space. So he decided to display the shortest prefix which doesn’t match with any prefix of any person who has joined earlier.

Let’s suppose the first person to enter the conference is alvin.Now suppose next person to join is alice.
在这里插入图片描述
The shortest prefix of alice that doesn’t match with any prefix of alvin is ali.
在这里插入图片描述

If the full name of a new person matches completely with the full name of any person who has joined earlier, he will display the full name and add a suffix which indicates how many times the same name has occurred in the list so far. For example, if another person name alvin joins, the list will look like this:
在这里插入图片描述

You are given the list of the persons who have joined the call in the chronological order. Your task is to figure out how the final list looks like.

简短的总结一下题意。
其实就是输出不重复的最大前缀。

2.分析

主要有两种做法,分别是字典树和map

2.1 字典树

暂无

2.2 map

主要实现过程如下:

  • step 1.判断每个人姓名的前缀是否出现在map中,如果出现过,则往下遍历,直到分析完整个字符串;否则直接输出,并且把当前的这个前缀写到map中。
  • step 2.接着分析下一个字符串。

例如:对于alvin这个人,依次写入

a
al
alv
alvi
alvin

并依次判断上述的字符串是否已经写到map中了,如果写过了,则依次往下遍历,直到遍历完整个字符串。如果整个姓名都已经出现过,则先输出姓名再输出该姓名出现的次数。
例如对于样例1

输入样例1
3
alvin
alice
alvin
输出样例1
a
ali
alvin 2
3.代码
#include<iostream>
#include<string>
#include<map>
using namespace std;

map<string,int> res;

int main(){
	ios::sync_with_stdio(false);
	cin.tie(0), cout.tie(0);
	
	int n;
	cin >> n;
	string s;
	for(int i = 0;i < n;i++){
		cin >> s;		
		string temp = "";
		int flag = 0;
		for(int j = 0;j < s.length()-1;j++){
			temp += s[j];
			if(res.find(temp) == res.end() ){
				if(flag == 0) {
					flag = 1;
					cout << temp <<"\n";	
				}
				res[temp] = 0;
			}
		}
		if(flag == 0){
			if( res[s] == 0 || res.find(s) == res.end() ){
				cout << s<<"\n";
				res[s] = 1;
			}
			else{
				int idx = res[s] + 1;
				cout << s << " "<< idx<<"\n";
				res[s] = idx; 	
			}			
		}
		else//
			res[s] = 1;
	}
}
4.测试用例

输入

5
alvin
alvin
alv 
alvin
alv

输出

a
alvin 2
alv 
alvin 3
alv 2
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

说文科技

看书人不妨赏个酒钱?

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值