A - 一二三

A - 一二三
Time Limit:1000MS    Memory Limit:65535KB    64bit IO Format:%I64d & %I64u

Description

你弟弟刚刚学会写英语的一(one)、二(two)和三(three)。他在纸上写了好些一二三,可惜有些字母写错了。已知每个单词最多有一个字母写错了(单词长度肯定不会错),你能认出他写的啥吗?

Input

第一行为单词的个数(不超过10)。以下每行为一个单词,单词长度正确,且最多有一个字母写错。所有字母都是小写的。

Output

对于每组测试数据,输出一行,即该单词的阿拉伯数字。输入保证只有一种理解方式。

Sample Input

3
owe
too
theee

Sample Output

1
2
3

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    int test,len,i,count1,count2;
    char s[6];
    char s1[]="one";
    char s2[]="two";
    char s3[]="three";
    scanf("%d",&test);
    while(test--)
    {
        scanf("%s",s);
        len=strlen(s);
        if(len>3)
        {
            printf("3\n");
        }
        else
        {
            count1=0;
            count2=0;
              for(i=0;i<len;i++)
              {

                  if(s[i]==s1[i])
                  {
                      count1++;
                  }
                  if(s[i]==s2[i])
                  {
                      count2++;
                  }
              }
              if(count1>=2)
              {
                  printf("1\n");
              }
              if(count2>=2)
              {
                  printf("2\n");
              }
        }
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值