HDU Tian Ji -- The Horse Racing

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14534    Accepted Submission(s): 4149


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0
这个题目的关键在于当田忌的马和国王的马速度一样时该如何分析,自己想了好久,始终一片混乱,看了别人的分析,才知道大脑清醒,思路清晰是有多么的重要。
(1)首先将国王的马和田忌的马按速度从快到慢排序。
(2)从两方最快的马开始比较:
1.如果田忌最快的马比国王最快的马要快,则直接比赛,田忌赢一局。
2.如果田忌最快的马比国王最快的马要慢,也直接比赛,田忌输一局。
3.如果田忌和国王最快的马速度是一样的。则要分情况考虑:
(1)如果田忌最慢的马比国王最慢的马快,则比赛,田忌赢一局。
(2)如果田忌最慢的马比国王最慢的马慢,则用田忌最慢的马与国王当前最快的马比(因为直接用最快的马和国王最快的马比,在用最慢的马和国王比,田忌会输两局。而使用上述方法,田忌则会赢一局,输一局。比较二者。方案二结果更好)
(3)如果田忌最慢的马和国王最慢的马速度一样快,且田忌当前最快的马比国王最慢的马要快,则田忌用最慢的马和国王最快的马比,用最快的马和国王最慢的马比(因为直接用最快的马和国王最快的马比,在用最慢的马和国王比,田忌会输一局,平一局。而使用上述方法,田忌则会赢一局,输一局。比较二者。方案二结果更好)
#include<iostream>
#include<algorithm>
using namespace std;
int a[1010],b[1010];
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int n;
	int i,j,ti,ki,tj,kj,win;
    while(true)
	{
		scanf("%d",&n);
		if(n==0)
		{
			break;
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&b[i]);
		}
        sort(a,a+n,cmp);
		sort(b,b+n,cmp);
		ti=0;
		ki=0;
		tj=n-1;
		kj=n-1;
		win=0;
		for(i=0;i<n;i++)
		{
			if(a[ti]>b[ki])
			{
				ti++;
				ki++;
				win++;
			}
			else if(a[ti]<b[ki])
			{
				tj--;
				ki++;
				win--;
			}
			else
			{
                 if(a[tj]>b[kj])
				 {
					 tj--;
					 kj--;
					 win++;
				 }
				 else if(a[tj]<b[kj])
				 {
					 tj--;
					 ki++;
					 win--;
				 }
				 else
				 {
					 if(a[tj]<b[ki])
					 {
						  tj--;
						  ki++;
						  win--;
					 }
				 }
			}
		}
		printf("%d\n",win*200);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值