第六届福建省大学生程序设计竞赛-重现赛,Problem C Knapsack problem【大背包】

Problem C Knapsack problem

Accept: 83    Submit: 457
Time Limit: 3000 mSec    Memory Limit : 32768 KB

 Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

 Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

 Output

For each test case, output the maximum value.

 Sample Input

1
5 15
12 4
2 2
1 1
4 10
1 2

 Sample Output

15

题意:给你n个物品,你的背包的重量限制是B,输入n个w[i]重量  v[i]价值。求不超过B的情况下,背包内物品的价格最大。

思路:由于B的上限较大,转化下思路就好了。设置dp[i][j]为前i个物品获得价值为j时所需的最小容量。

状态转移 dp[i][j] = min(dp[i-1][j], dp[i][j-val[i]] + w[i])。优化掉一维就可以了。

ac-code:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MAXN (500+10)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
#define PI acos(-1.0)
using namespace std;
int dp[10000];
int w[MAXN], v[MAXN];
int main()
{
    int t;Ri(t);
    W(t)
    {
        int n, W, sumv;
        scanf("%d%d",&n, &W);
        sumv=0; CLR(dp, INF); dp[0]=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&w[i],&v[i]);
            sumv+=v[i];
        }
        for(int i=0;i<n;i++)
            for(int j=sumv;j>=v[i];j--)
                dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
        for(int j=sumv;j>=0;j--)
        {
            if(dp[j]<=W)
            {
                printf("%d\n",j);
                break;
            }
        }
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值