Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18437 Accepted Submission(s): 13833
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1 2 3
Sample Output
1 10 11
ACcode:
#include<stdio.h>
int main()
{
int i,j,k,l;
__int64 m[100];
while(scanf("%d",&i)!=EOF)
{
k=i;
for(j=0;j<100;j++)
{
m[j]=k%2;
k=k/2;
if(k==0) break;
}
for( ;j>=0;j--)
printf("%I64d",m[j]);
printf("\n");
}
return 0;
}