poj 2188 Cow Laundry

Cow Laundry
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1058 Accepted: 694

Description

The cows have erected clothes lines with N (1 <= N <= 1000) wires upon which they can dry their clothes after washing them. Having no opposable thumbs, they have thoroughly botched the job. Consider this clothes line arrangement with four wires: 
牛们用N (1 <= N <= 1000)根电线组了个晒衣绳用来晒衣服。由于没有对生手指(好吧,反正翻译是这么说的,牛没有,人有),他们没办法很好的完成这个任务。用四根电线拉成的晒衣绳如下
   Wire slot: 1   2    3    4

              ---------------   <-- the holder of the wires

              \    \  /    /

               \    \/    /

                \   /\   /       

                 \ /  \ /       <-- actual clothes lines

                  /    \

                 / \  / \

                /   \/   \

               /    /\    \

              /    /  \    \

              ---------------   <-- the holder of the wires

   Wire slot: 1   2    3    4

The wires cross! This is, of course, unacceptable.
电线纠缠到一起了!当然,这是很糟糕的......(我已经不知道在翻译神马了啊.....)
The cows want to unscramble the clothes lines with a minimum of hassle. Even their bovine minds can handle the notion of "swap these two lines". Since the cows have short arms they are limited to swapping adjacent pairs of wire endpoints on either the top or bottom holder. 
牛们希望用最少步骤来整理晾衣绳。好吧,牛似乎能够理解的概念就是“交换这些线其中的两条”。也就是说每次只能交换相邻的两条线
In the diagram above, it requires four such swaps in order to get a proper arrangement for the clothes line: 
在上面显示的那种混乱中,一共需要4次交换就能整理好晾衣绳如下。。
              1   2   3   4

              -------------   <-- the holder of the wires

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              |   |   |   |

              -------------   <-- the holder of the wires

              1   2   3   4

Help the cows unscramble their clothes lines. Find the smallest number of swaps that will get the clothes line into a proper arrangement.
帮助牛们整理晾衣绳,并找到最少的交换次数。
You are supplied with clothes line descriptions that use integers to describe the current ordering of the clothesline. The lines are uniquely numbered 1..N according to no apparent scheme. You are given the order of the wires as they appear in the N connecting slots of the top wire holder and also the order of the wires as they appear on the bottom wire holder.
提供给你的是晾衣绳的上端数据和下端数据,数据排列从1...N。

Input

* Line 1: A single integer: N
第一行:一个单独的整数,N
* Lines 2..N+1: Each line contains two integers in the range 1..N. The first integer is the wire ID of the wire in the top wire holder; the second integer is the wire ID of the wire in the bottom holder. Line 2 describes the wires connected to top slot 1 and bottom slot 1, respectively; line 3 describes the wires connected to top and bottom slot 2, respectively; and so on.
第二行..N+1:每一行有两个整形数据从1..N。第一个整形是位于上边的电线ID,第二个就是下面的电线头ID。第一组数据就是说4号电线对应着1号电线。

Output

* Line 1: A single integer specifying the minimum number of adjacent swaps required to straighten out the clothes lines.
一个整形数据输出最小的交换次数。

Sample Input

4
4 1
2 3
1 4
3 2

Sample Output

4

Source

 

这道题的叙述很符合美国一贯的作风......繁杂不过好像蛮有趣,由于是交换相邻两条,于是顺理成章的变成了逆序数的问题。只要先把对应位置找好,然后就计算一下逆序数就可以了......
 

#include <iostream>
#include <cmath>
#include <algorithm>
#include <stdio.h>
#include <string.h>

#define MAXINT 1111
#define LENGTH 1111

void Merge_sort(int a[LENGTH], int p, int r);
void Merge(int a[LENGTH], int p, int q, int r);

int inve_sum = 0;

int main(void)
{
	int top[LENGTH], bottom[LENGTH], a[LENGTH];
	int N;

	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);

    while(scanf("%d", &N)!= EOF){
    	for (int i = 0;i < N;i ++){
        	scanf("%d %d", &top[i], &bottom[i]);
    	}
    	for (int i = 0;i < N;i ++){
        		for (int j = 0;j < N;j ++){
            		if (top[i] == bottom[j]){
                			a[i] = j;
				break;
			}
        		}
    	}
	inve_sum = 0;
    	Merge_sort(a, 0, N - 1);
    	printf("%d\n", inve_sum);
    }
    return 1;
}

void Merge_sort(int a[LENGTH], int p, int r){
    int q;
    if (p < r){
        q = (p + r) >> 1;
        Merge_sort(a, p, q);
        Merge_sort(a, q + 1, r);
        Merge(a, p, q, r);
    }
}

void Merge(int a[LENGTH], int p, int q, int r){
    int L[(LENGTH >> 1) + 1], R[(LENGTH >> 1) + 1];
    int n1 = 0, n2 = 0;

    for (int i = p;i <= q;i ++){
        L[n1++] = a[i];
    }
    L[n1] = MAXINT;

    for (int i = q + 1;i <= r;i ++){
        R[n2++] = a[i];
    }
    R[n2] = MAXINT;

    n1 = 0, n2 = 0;
    for (int k = p;k <= r; k++){
        if (L[n1] <= R[n2]){
            a[k] = L[n1];
            n1++;
        }else{
            a[k] = R[n2];
            inve_sum += q - p + 1 - n1;
            n2++;
        }
    }
}


深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值